When a certain site creation template is missing from a SharePoint subsite, how to fix this?

No comments

Issue Description:

While we go for subsite creation from a SharePoint site – quite often we may see some of the templates are not available in the template selection – it may be team site, blog site or any other site template. We will see here what is the root cause of this issue and its fixes.

Site Creation Template selection

 

How to handle or fix the above issue?

Step 1:

Activate the “SharePoint Server Publishing Infrastructure ” feature from the site collection level.

Example:

“https://globalsharepoint.sharepoint.com/sites/TestSite/

_layouts/15/ManageFeatures.aspx?Scope=Site”

SharePoint Server Publishing Infrastructure

Step 2:

Go to your “http://<yourportal or online site URL>/_Layouts/AreaTemplateSettings.aspx”

Example:

“https://globalsharepoint.sharepoint.com/sites/TestSite/

_layouts/15/AreaTemplateSettings.aspx”

In the below page verify that which radio button is selected for “Subsite Templates“. Generally if the second radio button i.e. “Subsites can use any site template“, we should get all the templates in the subsite those are available in the site collection. However, if the third radio button is selected i.e. “Subsites can only use the following site templates” then we need to configure the templates accordingly – so that we will not face issue while selecting the templates from the subsites.

Site Creation Template selection3

Notes:

If we do not activate “SharePoint Server Publishing Infrastructure ” feature from the site collection level and try to access the “http://<yourportal or online site URL>/_Layouts/AreaTemplateSettings.aspx” page, we will get the below error:

Site Creation Template selection2